Will not boot on Raspberry PI 2 after setup-alpine & lbu commit

7 posts / 0 new
Last post
#1 Wed, 2017-02-15 18:36
  • cannibal3004's picture
  • Offline
  • Last seen: 1 year 1 week ago
  • Joined: 2017-02-15

I am trying to install Alpine on my Raspberry Pi 2. The sdcard boots fine when it is first created and everything appears to work properly. However after I run setup-alpine to configure the system and lbu_commit to save the changes to the SD card it will no longer boot. It sits at a black screen and the activity LED for the SD card makes the faintest flash every few seconds but I never get anything on the monitor. With no output to the monitor I'm not sure what the problem could be. Has anyone seen this issue before, or know what might be causing it?

Sun, 2017-02-26 00:17
  • mharsch's picture
  • Offline
  • Last seen: 12 months 3 days ago
  • Joined: 2017-02-26

I can reproduce this issue on my Pi 1 Model B. It's consistent with Alpine 3.5.1 and 3.5.0. Version 3.4.6 works fine.

Sun, 2017-02-26 16:42
  • mharsch's picture
  • Offline
  • Last seen: 12 months 3 days ago
  • Joined: 2017-02-26

The root cause of this issue is this bug: https://bugs.alpinelinux.org/issues/6668

The boot files must be updated on the SD media after initial boot+configuration (setup-alpine) as described in the bug. However, I'd suggest the following changes to the workaround procedure described in the bug:
1.) Use the boot files from the exact commit referenced by the fix (rather than from the raspberry pi master branch).
2.) Modifying the config.txt file is unnecessary.
3.) with the new firmware, you'll need to add the line 'enable_uart=1' to config.txt if you're using the serial console -- see this reference: https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=141195

Mon, 2017-08-28 23:12 (Reply to #3)
  • gmbyby's picture
  • Offline
  • Last seen: 5 months 3 weeks ago
  • Joined: 2017-08-28

I'm still having this issue on 3.6.2 even after following your steps on bug 6668. Any thoughts?

Sun, 2017-09-03 16:35
  • richardh's picture
  • Offline
  • Last seen: 5 months 2 weeks ago
  • Joined: 2017-09-03

I have just tried alpine 3.6.2 on a Pi 1B and am seeing this issue.

I have been through the remedial steps listed for bug no. 6668 but the problem remains.

Any hints?


Wed, 2017-10-18 03:28
  • rdamron's picture
  • Offline
  • Last seen: 4 months 1 week ago
  • Joined: 2017-10-18

Also having this problem on 3.6.2 on a RPi3.
If 3.4.6 is really the last working build this bug has existed for 9 months now?

Tomorrow i'll connect via UART and see what the output is maybe there is some information to be had here.

Tue, 2017-10-31 16:45
  • yaron's picture
  • Offline
  • Last seen: 1 month 3 weeks ago
  • Joined: 2017-10-31

I think I was able to bypass this by copying the <HOSTNAME>.apkovl.tar.gz to /media/mmcblk0p1/rpi.apkovl.tar.gz after running mount -o rw,remount /media/mmcblk0p1.

My lbu location is /media/mmcblk01p2 of course.

Log in or register to post comments