WARNING: Ignoring APKINDEX.7c1f02d6.tar.gz: No such file or directory

2 posts / 0 new
Last post
#1 Fri, 2017-11-24 16:15
ArchaicDev
  • ArchaicDev's picture
  • Offline
  • Last seen: 2 weeks 3 days ago
  • Joined: 2017-11-24

Hello,
I am working on Dokerizing an apache and PHP application. I wanted to use Alpine as its very small and secure.
Seems that I can't RUN apk update.

I used alpine:edge, alpine:3.3 and apline 3.6

I get the same error message every time which makes me think there is an issue with the update package. Below i have added all the steps and deatils I can.

I haven't used Apline before so could be I have done something wrong. I am also fairly new to Linux and Docker.

In Docker File I simply have

FROM alpine:edge
 
RUN apk update

I then run the command

    docker build -t alpine_apache_server .

I then get the following error
fetch <a href="http://dl-cdn.alpinelinux.org/alpine/v3.3/main/x86_64/APKINDEX.tar.gz
ERROR:" rel="nofollow">http://dl-cdn.alpinelinux.org/alpine/v3.3/main/x86_64/APKINDEX.tar.gz
ERROR:</a> <a href="http://dl-cdn.alpinelinux.org/alpine/v3.3/main:" rel="nofollow">http://dl-cdn.alpinelinux.org/alpine/v3.3/main:</a> temporary error (try again later)
WARNING: Ignoring APKINDEX.5a59b88b.tar.gz: No such file or directory
fetch <a href="http://dl-cdn.alpinelinux.org/alpine/v3.3/community/x86_64/APKINDEX.tar.gz
ERROR:" rel="nofollow">http://dl-cdn.alpinelinux.org/alpine/v3.3/community/x86_64/APKINDEX.tar.gz
ERROR:</a> <a href="http://dl-cdn.alpinelinux.org/alpine/v3.3/community:" rel="nofollow">http://dl-cdn.alpinelinux.org/alpine/v3.3/community:</a> temporary error (try again later)
WARNING: Ignoring APKINDEX.7c1f02d6.tar.gz: No such file or directory
2 errors; 11 distinct packages available

So I go to the URL: http://dl-cdn.alpinelinux.org/alpine/v3.3/community/x86_64/
That is up and I see APKINDEX.tar.gz
I can download that.
When I go go into that package there are 3 files and then I don't know what I am looking at but I dont see anything named apkinxed.5a59b88b anywere.

So, I took out the update command from Dockerfile.

I ran just the FROM apline:xxx

I then use docker run -id [container] bin/bash

I go into the container and then run apk update inside the container and still I get the same error message.

I don't know what else I can do.

Wed, 2017-11-29 13:58
ArchaicDev
  • ArchaicDev's picture
  • Offline
  • Last seen: 2 weeks 3 days ago
  • Joined: 2017-11-24

OK, so today I revisited this. I ran Docker build and the apk update command ran and worked fine.

What's the difference?
When I posted this I was using my home internet connection. Today I am at work using their internet.

I will test again at home tonight. If it works then it suggests something was wrong last Friday and it would be nice to be informed as to what the issue was.

Otherwise that suggests you fixed this without saying anything, which is a little rude.

Log in or register to post comments