Set system-wide limits

1 post / 0 new
#1 Tue, 2017-12-19 20:58
  • alKash's picture
  • Offline
  • Last seen: 2 months 3 weeks ago
  • Joined: 2017-12-19

Due to constant RLIMIT_NOFILE oversteps by Xorg, I've been trying to increase the per-process open file descriptor limit. (Note: not the kernel file-max limit.) There does not seem to be any information on how to do this under Alpine. Setting the rc_ulimit variable in /etc/rc.conf to -n 16384 has no effect—the file descriptor limit is still reported as 1024 after reboot. The Busybox ulimit(1) builtin allows limits to be set for the current shell when run by root, but this does not affect processes run in other shells.

I've also installed linux-pam and set nofile limits in /etc/security/limits.conf, to no effect.

Have I missed some obvious configuration process that would let me change resource limits? Any help would be greatly appreciated.

EDIT: Running Alpine 3.7.0, 4.9.65-1-hardened on x86_64.