Edge package installation

2 posts / 0 new
Last post
#1 Tue, 2017-11-21 18:01
vincent.tr
  • vincent.tr's picture
  • Offline
  • Last seen: 3 weeks 1 day ago
  • Joined: 2017-11-21

Hi,

I'm, currently using alpine 3.6 armhf.
I'm trying to use the last nodejs LTS : 8.9.1.
The currently provided is 6.10.3

I'm trying to install it from the edge repository:
- From here, it seems to be at the version I'm looking for since 11/09 : https://pkgs.alpinelinux.org/packages?name=nodejs&branch=&repo=main&arch=armhf&maintainer=
- Following the instructions here : https://wiki.alpinelinux.org/wiki/Alpine_Linux_package_management#Add_a_Package
I tried this command apk add nodejs --update-cache --repository <a href="http://dl-3.alpinelinux.org/alpine/edge/testing/" rel="nofollow">http://dl-3.alpinelinux.org/alpine/edge/testing/</a> --allow-untrusted
But it still installs version 6.10.3.

Any advice on how to get the version 8.9.1 ?

Thanks in advance

Thu, 2017-11-23 14:12
vincent.tr
  • vincent.tr's picture
  • Offline
  • Last seen: 3 weeks 1 day ago
  • Joined: 2017-11-21

I could do it this way :

wget <a href="http://dl-3.alpinelinux.org/alpine/edge/main/armhf/nodejs-npm-8.9.1-r0.apk
wget" rel="nofollow">http://dl-3.alpinelinux.org/alpine/edge/main/armhf/nodejs-npm-8.9.1-r0.apk
wget</a> <a href="http://dl-3.alpinelinux.org/alpine/edge/main/armhf/libuv-1.15.0-r0.apk
wget" rel="nofollow">http://dl-3.alpinelinux.org/alpine/edge/main/armhf/libuv-1.15.0-r0.apk
wget</a> <a href="http://dl-3.alpinelinux.org/alpine/edge/main/armhf/nodejs-8.9.1-r0.apk
apk" rel="nofollow">http://dl-3.alpinelinux.org/alpine/edge/main/armhf/nodejs-8.9.1-r0.apk
apk</a> add --allow-untrusted ./libuv-1.15.0-r0.apk
apk add --allow-untrusted ./nodejs-npm-8.9.1-r0.apk
apk add --allow-untrusted ./nodejs-8.9.1-r0.apk
apk del nodejs-npm
# test
node --version
node -e "console.log('hello')"

Is it the right way to do ?

I suppose I can experience conflict due to dependencies version mismatches

Log in or register to post comments