No audio in Audacious/Firefox - "GStreamer was unable to detect any sound devices"

5 posts / 0 new
Last post
#1 Wed, 2017-05-10 20:42
  • ReproducibleBuildsAreAGoodStandard's picture
  • Offline
  • Last seen: 2 weeks 4 days ago
  • Joined: 2017-05-05

Hi everyone! Alpine 3.5.2 setup on an HP laptop using xfce4. Created sudo user before launching slim, and desktop launches, but having tried installation three times, most times there is no sound in youtube or when other videos play in Firefox; there was no sound on Audacious later on two installations even with Settings/Audio/'SDL Output'. System beeps are heard.

I'm not sure whether the reason for the variations was the different ways of creating a sudo user or some other variation in the installation process.

Other symptoms:-
1. Audio Mixer/'xfce4-mixer' applet launches saying "GStreamer was unable to detect any sound devices. Some sound system specific GStreamer packages may be missing. It may also be a permissions problem."
2. sudo lspci | grep Audio returns nothing.
3. sudo cat  /etc/asound.conf returns No such file or directory.

Currently installed packages include: alsa-utils alsaconf pulseaudio@testing  aumix sox phonon-backend-gstreamer gst-plugins-bad0.10 gstreamer0.10 gstreamer0.10-tools gstreamer1 gstreamer1-doc gstreamer1-tools gstreamermm@testing ffmpeg fdk-aac@testing audacious-plugins vlc vlc-plugins-codec vlc-qt. However, I did not how to navigate aumix when following the instructions for aumix at

Also tried listing audio cards in desired order under /etc/modprobe.d/alsa-base.conf:

options HD-Audio Generic index=1
options HDA ATI HDMI index=0

Could it be a missing instruction, a permissions problem or a missing package?

Thu, 2017-05-18 16:42
Mateus R. Morei...
  • Mateus R. MoreiraCherrypie's picture
  • Offline
  • Last seen: 9 months 1 week ago
  • Joined: 2017-05-18

I resolved with root permissions adduser your_ser audio

Fri, 2017-05-26 21:43
  • ReproducibleBuildsAreAGoodStandard's picture
  • Offline
  • Last seen: 2 weeks 4 days ago
  • Joined: 2017-05-05

I've moved on to another distro for the moment; I still couldn't get Firefox to play audio, but audio usually (except for once!) played for video in Chromium although not for music websites e.g. not on In case it could help someone not to make the same errors, if I understood correctly, the following may help:

Correction 1.
Corrected the /etc/modprobe.d/alsa-base.conf entries that I reported above.
A helpful guide (although for Arch Linux) is at

# Find out the current order of sound cards and their index numbers
aplay -l
# For example, if the first entry ('card 0') there says 'HDMI', 
# you might not want that to get loaded first (as 'index 0') 
# unless the audio card that you use is connected to your pc with 
# an HDMI cable.
# Find out the names to use for those indexes-
cat /proc/asound/modules
# Then reorder those lines in your preferred order for sound cards 
# (card for index 1 is loaded before index 0 card by 
# listing it first).
sudo rnano -w /proc/asound/cards
# perhaps enter as follows
options snd_hda_intel index=1
options snd_hda_intel index=0
# Reboot to apply the above.

Correction 2.
Added user to audio group and, as another user for another distro seems to suggest, adding to other groups is handy also-

# Installed shadow first to obtain 'usermod' facility
sudo apk add shadow@testing 
usermod -a -G audio,lp,video,usb,cdrom,plugdev,netdev,power myusername

Thu, 2017-06-15 21:22
  • kgotfryd's picture
  • Offline
  • Last seen: 8 months 1 week ago
  • Joined: 2017-06-15

I've started alsa with these commands, executed as a root:

1. Check whether your OS sees your card - I've been using lspci (some info about sound card should be present) and alsamixer (run alsamixer as a root, then press f6). If you don't see anything it might be problem with driver (or driver is not present).
2. run "alsamixer", make sure master is on (i.e. 50%).
3. run "alsactl store".
4. Start alsa service with command "rc-service start alsa" and mark it for autostart "rc-update add alsa".
5. If there was warning about muted card, execute: "rc-service stop alsa", "alsactl store", "rc-service start alsa". If again you see some text about muted card, I don't know what can help it : /.
5. Add user (which will use sound card) into "audio" group with "addgroup -S (username) audio".

I have a question to the alpine developers/anyone who knows the answer - why apk does not start alsa service when package is installed? I just would like to see Your point of view.

Sat, 2017-07-15 07:34
  • ReproducibleBuildsAreAGoodStandard's picture
  • Offline
  • Last seen: 2 weeks 4 days ago
  • Joined: 2017-05-05

@Mateus R. MoreiraCherrypie - Thank you for your good point.

@kgotfryd - Thank you very much for your concern to help. It is a helpful post also, which could help in other distros as well, only one would need to change the syntax and expressions to the distro's service packages accordingly. I just noticed your post, as I have moved on to another distro but had a look to Alpine again, hoping that the sound issues are ok after all. Thank you!

Log in or register to post comments