Setting TCP keep alive values

2 posts / 0 new
Last post
#1 Sun, 2017-04-30 21:55
Chamara.G
  • Chamara.G's picture
  • Offline
  • Last seen: 1 month 3 weeks ago
  • Joined: 2017-04-30

Hello, I am trying to set the TCP keep alive values in Alpine Linux 3.5 and running into issues. The values are not present in /proc/sys/net/ipv4 and trying to set them via sysctl.conf gives me this error message:

/var/lib/app # sysctl -p
sysctl: error: 'net.ipv4.tcp_keepalive_time' is an unknown key
/var/lib/app #

background: I have an app that is running in an Alpine Linux Docker container deployed in AWS. The traffic is going through a NAT Gateway and it drops the connection if it is idle for more than 5 minutes. Therefore, I would like to enable TCP keep alive messages for this container.

Thank you.

Thu, 2017-05-18 16:50
s3ni0r
  • s3ni0r's picture
  • Offline
  • Last seen: 1 month 6 days ago
  • Joined: 2017-05-18

+1, i'm facing the same issue with :

bash-4.3# sysctl -w net.ipv4.tcp_fin_timeout="15"
sysctl: error: 'net.ipv4.tcp_fin_timeout' is an unknown key

Container info :

bash-4.3# cat /etc/*ele*
3.5.2
NAME="Alpine Linux"
ID=alpine
VERSION_ID=3.5.2
PRETTY_NAME="Alpine Linux v3.5"
HOME_URL="http://alpinelinux.org"
BUG_REPORT_URL="http://bugs.alpinelinux.org"
 
bash-4.3# uname -a
Linux 185f2a07e3bb 4.4.0-78-generic #99-Ubuntu SMP Thu Apr 27 15:29:09 UTC 2017 x86_64 Linux

Log in or register to post comments