No audio in Audacious/Firefox - "GStreamer was unable to detect any sound devices"

2 posts / 0 new
Last post
#1 Wed, 2017-05-10 20:42
ReproducibleBui...
  • ReproducibleBuildsAreAGoodStandard's picture
  • Offline
  • Last seen: 1 week 5 days ago
  • Joined: 2017-05-05

Hi everyone! Alpine 3.5.2 setup on an HP laptop using xfce4. Created sudo user before launching slim, and desktop launches, but having tried installation three times, most times there is no sound in youtube or when other videos play in Firefox; there was no sound on Audacious later on two installations even with Settings/Audio/'SDL Output'. System beeps are heard.

I'm not sure whether the reason for the variations was the different ways of creating a sudo user or some other variation in the installation process.

Other symptoms:-
1. Audio Mixer/'xfce4-mixer' applet launches saying "GStreamer was unable to detect any sound devices. Some sound system specific GStreamer packages may be missing. It may also be a permissions problem."
2. sudo lspci | grep Audio returns nothing.
3. sudo cat  /etc/asound.conf returns No such file or directory.

Currently installed packages include: alsa-utils alsaconf pulseaudio@testing  aumix sox phonon-backend-gstreamer gst-plugins-bad0.10 gstreamer0.10 gstreamer0.10-tools gstreamer1 gstreamer1-doc gstreamer1-tools gstreamermm@testing ffmpeg fdk-aac@testing audacious-plugins vlc vlc-plugins-codec vlc-qt. However, I did not how to navigate aumix when following the instructions for aumix at https://wiki.alpinelinux.org/wiki/Alpine_Linux:FAQ#How_do_I_play_my_.ogg.2F.mp3_files.3F.

Also tried listing audio cards in desired order under /etc/modprobe.d/alsa-base.conf:

options HD-Audio Generic index=1
options HDA ATI HDMI index=0

Could it be a missing instruction, a permissions problem or a missing package?

Thu, 2017-05-18 16:42
Mateus R. Morei...
  • Mateus R. MoreiraCherrypie's picture
  • Offline
  • Last seen: 4 days 20 hours ago
  • Joined: 2017-05-18

I resolved with root permissions adduser your_ser audio

Log in or register to post comments