MPD installs but crashes

1 post / 0 new
#1 Fri, 2015-01-30 16:50
angelus1969
  • angelus1969's picture
  • Offline
  • Last seen: 2 years 9 months ago
  • Joined: 2015-01-30

I'm trying to create a slim MPD player and thought Alpine would be the ideal OS for this. I have installed it on a harddrive, with the 'sys' option. Then I install mpd and mpc but when starting 'service mpd start' it seems to start, but then crashes right away according to /var/log/messages:

music:/run# service mpd start
* Starting mpd ...
Jan 30 16:48 : server_socket: bind to '0.0.0.0:6600' failed: Address in use (continuing anyway, because binding to '[::]:6600' succeeded) [ ok ]
music:/run# service mpd status
* status: crashed
music:/run# tail -20 /var/log/messages
Jan 30 15:43:07 music auth.info sshd[1325]: Received signal 15; terminating.
Jan 30 15:43:07 music auth.info sshd[1368]: Exiting on signal 15
Jan 30 16:43:07 music syslog.info syslogd exiting
Jan 30 16:43:41 music syslog.info syslogd started: BusyBox v1.22.1
Jan 30 15:43:41 music cron.info crond[1261]: crond: crond (busybox 1.22.1) started, log level 8
Jan 30 15:43:41 music daemon.err /etc/init.d/mpd[1302]: start-stop-daemon: failed to start `/usr/bin/mpd'
Jan 30 15:43:41 music daemon.err /etc/init.d/mpd[1287]: ERROR: mpd failed to start
Jan 30 15:43:42 music auth.info sshd[1325]: Server listening on 0.0.0.0 port 22.
Jan 30 15:43:42 music auth.info sshd[1325]: Server listening on :: port 22.
Jan 30 15:43:42 music daemon.info init: starting pid 1350, tty '/dev/tty1': '/sbin/getty 38400 tty1'
Jan 30 15:43:42 music daemon.info init: starting pid 1351, tty '/dev/tty2': '/sbin/getty 38400 tty2'
Jan 30 15:43:42 music daemon.info init: starting pid 1355, tty '/dev/tty3': '/sbin/getty 38400 tty3'
Jan 30 15:43:42 music daemon.info init: starting pid 1358, tty '/dev/tty4': '/sbin/getty 38400 tty4'
Jan 30 15:43:42 music daemon.info init: starting pid 1361, tty '/dev/tty5': '/sbin/getty 38400 tty5'
Jan 30 15:43:42 music daemon.info init: starting pid 1364, tty '/dev/tty6': '/sbin/getty 38400 tty6'
Jan 30 15:43:47 music auth.info sshd[1367]: Accepted password for root from 192.168.1.189 port 53061 ssh2
Jan 30 15:44:08 music daemon.err /etc/init.d/mpd[1386]: start-stop-daemon: failed to start `/usr/bin/mpd'
Jan 30 15:44:08 music daemon.err /etc/init.d/mpd[1373]: ERROR: mpd failed to start
Jan 30 15:45:01 music cron.info crond[1261]: crond: USER root pid 1401 cmd run-parts /etc/periodic/15min
Jan 30 15:48:41 music daemon.err /etc/init.d/mpd[1457]: status: crashed

No further reason for the crash. But strangely according to 'ps -ef' it's still running:
music:/run# ps -ef | grep -i mpd
1434 mpd 0:00 /usr/bin/mpd
1460 root 0:00 grep -i mpd

Another thing, when installing mpd, the directory /var/run/mpd is created for the pid file. After a reboot, this directory is gone! When trying to start mpd then generates another error offcourse, because it's missing the directory

Can anyone help?

--
Angelo