VirtualBox VM With xfce4 Desktop Not Able to Use Full Screen Resolution

1 post / 0 new
#1 Wed, 2017-08-30 08:16
Inkognitov
  • Inkognitov's picture
  • Offline
  • Last seen: 2 months 3 weeks ago
  • Joined: 2017-08-30

I have an installation of alpine linux running in a virtualbox vm with slim + xfce4 for the desktop engine.

Kernel Version: I have tried with both the latest (3.6.2) Standard and Virtual Kernel from https://alpinelinux.org/downloads/

I have not been able to get the guest to utilize the entire screen resolution, instead it is only able to go up to 1024x768. I was wondering if anyone could help me figure out what I'm missing/doing wrong. Below are the steps I've taken:

I followed the steps in this video: https://www.youtube.com/watch?v=1_bsycXrFcI

Standard Alpine Linux install:

#Using all repositories: 
apk update && apk upgrade
setup-xorg-base
apk add alpine-desktop
apk add xfce4
apk add thunar-volman
apk add faenza-icon-theme
apk add slim
rc-service dbus start
rc-update add dbus
rc-service udev start
rc-service add udev
rc-update add slim
reboot

Virtualbox Specific Packages:

Standard Kernel:

apk add virtualbox-guest-modules-grsec virtualbox-additions-grsec virtualbox-guest-additions-5.1.26-r0

 Virtual Kernel:

apk add virtualbox-guest-additions-5.1.26-r0
apk add virtualbox-guest-modules-grsec
"apk add virtualbox-guest-modules-grsec" give the following warning message:

depmod could not open /lib/modules/4.9.44-0-hardened/modules.order

I did NOT do the following:

apk add virtualbox-additions-grsec
Because that breaks my installation, only allows me to boot into the command prompt and spams the following error:

tty port_close_start: tty->count = 1 port count = 2

 Virtualbox Settings:

Version: 5.1.26 r117224 (Qt5.6.2)
VirtualBox > Preferences > Display > Maximum Guest Screen Size: None
View > Auto-resize Guest Display checked (It's greyed out, can't select it)
VM Settings > Display > Screen: Video Memory 128MB, 1 Monitor, 100% scale factor, Enable 3D Acceleration turned on