sfdisk and syslinux missing

9 posts / 0 new
Last post
#1 Thu, 2017-10-05 01:26
mac252
  • mac252's picture
  • Offline
  • Last seen: 1 week 4 days ago
  • Joined: 2017-10-05

Hello,

I am interested in trying Alpine Linux, so I downloaded the latest x86 iso and started the setup-alpine process, but got stuck when an error appeared.
The screen showed a message that sfdisk and syslinux and missing and sent me back to the # prompt.
I tried this twice with the same result.
Any clue?

Thu, 2017-10-05 15:02
ReproducibleBui...
  • ReproducibleBuildsAreAGoodStandard's picture
  • Offline
  • Last seen: 2 days 15 hours ago
  • Joined: 2017-05-05

- Although I am not familiar with the other Alpine Linux isos, as I have only ever used the 'Standard' iso (see its link at Downloads), maybe you should try that Standard iso if you have tried one of the smaller images: I wonder whether it contains the missing 'sfdisk' and 'syslinux'.
- Also, isn't your system 86_64, which is rather standard (for laptops/desktops) nowadays? You mentioned that you downloaded the x86 iso instead, which typically is for older 32-bit computers. Maybe that has something to do with it.

Thu, 2017-10-05 19:13
mac252
  • mac252's picture
  • Offline
  • Last seen: 1 week 4 days ago
  • Joined: 2017-10-05

Sorry I didn't specify.
Yes my system is i686 and the iso I used is the standard one.
I wondered if the error code might have to do with the fact that my hard disk has various partitions, but I don't see how it could be related with this kind of error output.

Thu, 2017-10-05 21:11
ReproducibleBui...
  • ReproducibleBuildsAreAGoodStandard's picture
  • Offline
  • Last seen: 2 days 15 hours ago
  • Joined: 2017-05-05

If you have another operating system installed on the other partitions, please bear in mind that Alpine's bootloader is not Grub2, which is so common in other Linux/GNU systems, but rather syslinux (see wiki for further info). I wonder whether that is the rub - there might be a clash if so. My Linux knowledge is not advanced, mind you.
By the way:
1. When you ran setup-alpine, you know that you would have to select 'sda' as the disk target, and then 'sys' in the next question (see Install to disk)?
2. You know that your partitioning would probably be rearranged automatically by setup-alpine - and thus your data would be altered?
Good luck!

Sat, 2017-10-07 16:53
ReproducibleBui...
  • ReproducibleBuildsAreAGoodStandard's picture
  • Offline
  • Last seen: 2 days 15 hours ago
  • Joined: 2017-05-05

Is it also possible that what you got is not a root prompt but rather a different system prompt (a bootloader prompt maybe?) because the image was malformed on your usb/DVD, etc? A common way that this could have happened is if your medium (if it was a usb drive) was mounted when you dd'd the iso onto it. It should be unmounted when starting the dd process, but some desktop environments will automatically mount the usb when you plug it in, and sometimes there is no notice to that effect. So you could try to re-burn the iso again this way:
Plug in your usb
Open a terminal
cd to location of your .iso file

sudo fdisk -l      # this will help you identify 
                   # your usb's drive name, say, sdy
sudo umount /dev/sdy
sudo dd bs=4M if=alpine-standard-3.6.2-x86.iso of=/dev/sdy status=progress && sync

(Note that the last two lines should be entered as one line - from sudo dd onwards.)

I hope this helps; maybe the Alpine wiki could be updated to make it clear that the destination usb needs to be unmounted before the dd process. This type of mistake has been reported elsewhere (I did this mistake in the past at least once; and see a similar report at another distro).

Does anyone else have any idea why there could be a sfdisk and syslinux missing error otherwise?

Fri, 2017-10-06 21:33
mac252
  • mac252's picture
  • Offline
  • Last seen: 1 week 4 days ago
  • Joined: 2017-10-05

hi,
yes I am aware that the USB must be unmounted before you do the DD copy.
I'm always careful to do that, which does not exclude that the error I got might be due to a flawed image.
I was just curious if the issue might be due to something wrong that I did (or didn't) do during the install process, since it's my first time with Alpine Linux.
I'm going to download the .iso again and try once again from scratch.

Sun, 2017-10-08 08:11
mac252
  • mac252's picture
  • Offline
  • Last seen: 1 week 4 days ago
  • Joined: 2017-10-05

hello again,

Ok, the standard .iso gave me the same error over and over, even if I downloaded and burned it again.
Always missing syslinux.
Anyway, I downloaded the extended .iso, which seems to work fine, booted, logged in and did the following:

mounted my target partition:

mnt -t ext4 /dev/sda3 /mnt<code>
 
installed Alpine:
 
<code> setup-disk -m sys /mnt<code>
 
Rebooted into Debian, ran blkid to obtain the UUID of the partition where Alpine is installed and edited /etc/grub.d/40_custom accordingly:
<code>
menuentry 'Alpine Linux' {
  set root='hd0,3'
  linux /boot/vmlinuz-hardened root=UUID=d7ac6c00-387d-4ea4-87f9-f70256411ef9
  initrd  /initramfs-hardened
}
<code>
 
Alpine boots but goes into kernel panic:
 
<code>
[2.530017] Kernel Offset: disabled
[2.530017] --- end Kernel Panic - non syncing: VFS:
Unable to mount root fs on unknown - block (0,0) <code>
 
Are the parameters I entered in 40_custom wrong or did I miss some steps during the install process? 
My goal is to install Alpine, dual booting it with Debian.

Tue, 2017-10-10 00:09 (Reply to #7)
ReproducibleBui...
  • ReproducibleBuildsAreAGoodStandard's picture
  • Offline
  • Last seen: 2 days 15 hours ago
  • Joined: 2017-05-05

Not that I have ever dual-booted with Alpine, I notice that some of your syntax for grub is at variance with a model for /etc/grub.d/40_custom in this wiki passage:
- Did you remember to update-grub2?
- Different types of quotation marks in that 40_custom file
- Quotation marks used for set root instead of round brackets
- Indeed, you ask about the linux command line parameters, which are different in that wiki page also.
I hope this helps: just trying to keep the forum responding!

Tue, 2017-10-10 06:26
mac252
  • mac252's picture
  • Offline
  • Last seen: 1 week 4 days ago
  • Joined: 2017-10-05

Hello,
I was finally able to dual boot Alpine using this entry in /etc/grub.d/40_custom:

menuentry "Alpine Linux" {
	set root=(hd0,3)
	linux /boot/vmlinuz-hardened root=UUID=eaa4452c-284b-4574-b879-b3ed72d6b98f modules=sd-mod,usb-storage4,ext3 quiet
	initrd /boot/initramfs-hardened
}
EOF
<code>
 
Where the UUID is the one from blkid /sda3
However in Alpine /boot directory there is a link to the /boot directory of my main disro.
Is that normal? 

Log in or register to post comments