Alpline Linux 3.6.0 as Virtualbox Guest - no resizing

12 posts / 0 new
Last post
#1 Mon, 2017-05-29 00:16
jradxl
  • jradxl's picture
  • Offline
  • Last seen: 2 months 3 weeks ago
  • Joined: 2017-05-28

Hi,
I have Alpine Linux (standard / sys ) running as a Guest in Virtualbox 5.1.22 running with Xfce4 and Mate working.
But re-sizing of the display does not work - max available is 1024x768.
Cut and Paste between the Host and Guest also does not work.

However dmesg shows that the three vbox modules are loaded.

apk info virtualbox-additions-grsec shows version 4.9
so I imagine that is the reason.

Is there a up to date Guest Additions, or can I compile my own?

Thx
John
alpine-standard-3.6.0-x86_64

Wed, 2017-05-31 02:34
jradxl
  • jradxl's picture
  • Offline
  • Last seen: 2 months 3 weeks ago
  • Joined: 2017-05-28

Ok, I've now realised that the Package name, such as "virtualbox-additions-hardened-4.9.30-r0" is referring to the Kernel Version number.
Looking at the code, I see that this version is for Virtualbox 5.1.14, so that is probably why I don't have resizing working.
Pity...

Wed, 2017-06-07 15:53
winux
  • winux's picture
  • Offline
  • Last seen: 2 months 3 weeks ago
  • Joined: 2017-06-07

Hi,

have you been able to resize now? I am running into the same problem with the most recent versions (Alpine, Virtualbox) and have no idea what to do else. I really need the seamless mode.

Anybody else an additional idea?

Thnx

winux

Wed, 2017-06-07 17:23
jradxl
  • jradxl's picture
  • Offline
  • Last seen: 2 months 3 weeks ago
  • Joined: 2017-05-28

Hi @winux
Not yet...
I digressed to get x2goserver working, as that gives resizing. X2goserver is really good.

I'm finding the problem with the guest additions is two fold
1. The vbox video library is not loading. modprobe just gives an unhelpful message
2. There is no VBoxClient being built.

I intend to return to this task over the next few days and will post here my findings.
For example, I want to try a Alpine Vanilla image in case it is the hardened kernels that are preventing the load.

Meanwhile, x2goserver is the work around.

Cheers
John

Thu, 2017-06-08 12:09
winux
  • winux's picture
  • Offline
  • Last seen: 2 months 3 weeks ago
  • Joined: 2017-06-07

Hi John,

as far as I see, vboxguest module is loaded (in my case). vboxvideo is NOT. I'm not that deep in Linux anymore to figure out why and how to change this.

I'm using alpine-standard-3.6.1-x86_64 in VirtualBox 5.1.22 r115126, but alpine-virt-3.6.1 shows the same behaviour. I guess it is the missing module but have no idea how to fix it.

Cheers

winux

Mon, 2017-06-12 18:34
winux
  • winux's picture
  • Offline
  • Last seen: 2 months 3 weeks ago
  • Joined: 2017-06-07

Hi,

now I have tried it with different Kernels including Vanilla. Still I am not able to load the vbox modules to get a resizable screen within Virtualbox.

I also tried the Kernel optimized for VMs. When installing the virtualbox-additions it installs the hardened kernel as well. When booting this, lsmod shows the vboxvideo module, but due to other errors the system does not come up clearly. I am not good enough in linux to understand an fix, and do not have any other ideas. I extremely regret but will give up at this point. Of course it would be very happy if you (or someone else) have additional ideas.

Cheers

Winux

Mon, 2017-06-12 19:06
jradxl
  • jradxl's picture
  • Offline
  • Last seen: 2 months 3 weeks ago
  • Joined: 2017-05-28

Hi @winux
See Bug #7421 I've just raised..
See Bug #7406 raised on similar subject.

The VirtualBox Vboxvideo.ko module requries DRM to be loaded, and as far as I can see is provided by MESA package
Bit I think it is all out of date
Watch the Bug report

Mon, 2017-09-04 12:28
winux
  • winux's picture
  • Offline
  • Last seen: 2 months 3 weeks ago
  • Joined: 2017-06-07

Hi John or anybody who could help,

coming back to the issue after almost three months: Have you (or someone else) been able to get the guest additions within a Virtualbox running with resizable display now?

Thanks in advance

Winux

Mon, 2017-09-04 17:54
jradxl
  • jradxl's picture
  • Offline
  • Last seen: 2 months 3 weeks ago
  • Joined: 2017-05-28

Hi Winux
Thanks for responding.
No I haven't. Summer holidays have got in the way!!

I was digressed for some time as LinuxHeaders is included in build and are for 4.4. But then realised this is only used for ./configure complier checking.

My next step was to check each and every build option as per Virtualbox's build instructions but haven't had time.

I'm sure for someone with a detailed knowledge of compiling for Xorg it's an easy fix. But for me I'm having to work from beginning.

I was hoping to learn how to debug a kernel to see if I could find out why the library wasn't loading.

All this from memory as I'm still on hols in Colombia!!
Thx
John

Tue, 2017-09-05 06:40
Inkognitov
  • Inkognitov's picture
  • Offline
  • Last seen: 2 months 3 weeks ago
  • Joined: 2017-08-30

Hey there! I'm also encountering the same issue, I have all the details here: https://forum.alpinelinux.org/forum/installation/virtualbox-vm-xfce4-desktop-not-able-use-full-screen-resolution

I'm still at a loss on how to resolve the issue, if either of you guys figure it out please let me know. Similarly if I come across a solution I will be sure to update both threads (this one and the linked one).

Tue, 2017-09-05 06:10
Inkognitov
  • Inkognitov's picture
  • Offline
  • Last seen: 2 months 3 weeks ago
  • Joined: 2017-08-30

Sorry, web browser bugged out and I posted twice.

Tue, 2017-11-14 18:50
NuSkool
  • NuSkool's picture
  • Offline
  • Last seen: 1 week 1 day ago
  • Joined: 2017-02-26

I fired up my virtual Alpine install today to check out some stuff unrelated to this vbox addition thing. It seems all the modules are loading, but still stuck on limited resolution and no shared clipboard. Anyone have anything to add or news on this?

Although a fully functional vbox install is likely FAR from the intended or targeted use case, it would be nice to have this working none the less. As an arch user, I'm thinking along the lines of running an initramfs from ram, with persistent changes possibly wrote to a USB. Figured this would be the best distro to figure out some of this stuff. I may just go ahead and do an install on some real hardware to see what I can learn.

I 'd also like to congratulate and thank the Alpine team for providing a tiny, secure, versatile, and very cool distro! I feel quite comfortable using this coming from Arch. Now if I was only skilled enough to get this going on one of my Pogo plugs.

$ cat /etc/alpine-release
3.6.0

# cat  /etc/apk/repositories
#/media/cdrom/apks
#http://dl-cdn.alpinelinux.org/alpine/v3.5/main
#http://dl-cdn.alpinelinux.org/alpine/v3.5/community
http://dl-cdn.alpinelinux.org/alpine/edge/main
http://dl-cdn.alpinelinux.org/alpine/edge/community

# uname -r
4.9.60-0-hardened

# apk info -ev virtualbox-guest-additions virtualbox-guest-modules-virthardened
virtualbox-guest-additions-5.1.26-r0
virtualbox-guest-modules-virthardened-4.9.60-r0

# dmesg | grep vbox
[   10.012355] vboxguest: loading out-of-tree module taints kernel.
[   10.026084] vboxguest: misc device minor 58, IRQ 20, I/O port d020, MMIO at 00000000f0400000 (size 0x400000)
[   10.026087] vboxguest: Successfully loaded version 5.1.26 (interface 0x00010004)
[   13.717461] vboxdrv: Found 2 processor cores
[   13.720252] vboxdrv: fAsync=0 offMin=0x5ff offMax=0x496ae
[   13.820556] vboxdrv: TSC mode is Synchronous, tentative frequency 2505690743 Hz
[   13.820558] vboxdrv: Successfully loaded version 5.1.26 (interface 0x002a0000)
[   13.825671] vboxpci: IOMMU not found (not registered)

# lsmod | grep box
vboxnetflt             23543  0
vboxpci                19220  0
vboxdrv               468861  2 vboxnetflt,vboxpci
vboxguest             289154  0

Log in or register to post comments