rsyslog or syslog-ng truncate log message always at 1K

1 post / 0 new
#1 Tue, 2017-08-29 15:03
stefanocog
  • stefanocog's picture
  • Offline
  • Last seen: 3 weeks 3 days ago
  • Joined: 2017-08-29

Hi,
it's my first post here...i use a official php-fpm alpine container and i installed rsyslog to manage my system logs, i have correctly configured rsyslog with this conf:

$MaxMessageSize 16k
$ModLoad imuxsock # provides support for local system logging
$ModLoad imklog   # provides kernel logging support
$KLogPermitNonKernelFacility on
$ActionFileDefaultTemplate RSYSLOG_TraditionalFileFormat
$FileOwner root
$FileGroup adm
$FileCreateMode 0640
$DirCreateMode 0755
$Umask 0022
*.*;auth,authpriv.none          -/var/log/syslog

Message in /var/log/syslog are always truncated at 1K instead 16K, same scenario with syslog-ng, with this conf:
@version: 3.7
options { log_msg_size(16384); owner("root"); group("adm"); perm(0640); };
source s_local { unix-dgram("/dev/log"); internal(); };
destination d_file { file("/var/log/syslog"); };
log { source(s_local); destination(d_file); };

Also with syslog-ng truncated message at 1K. Same configurations works fine into ubuntu docker container.
Is there a limitation of the official alpine docker container?

Thanks
Stefano