how to make this command working on busybox

2 posts / 0 new
Last post
#1 Sat, 2017-04-29 12:43
debiansid
  • debiansid's picture
  • Offline
  • Last seen: 2 months 2 weeks ago
  • Joined: 2017-03-25

  sed -e 's%#include <ipset%#include <libcorkipset%' \
      -e 's%#include "ipset%#include "libcorkipset%' \
      -i include/ipset/*.h */*/*/*.c */*/*/*.c.in */*/*.c */*.c
  mv include/{,libcork}ipset

those working on archlinux, but not on alpine linux, I thought it is caused by busybox.
any idea how to fix it ?

thanks

Tue, 2017-05-30 00:39
Franklin Yu
  • Franklin Yu's picture
  • Offline
  • Last seen: 1 month 3 weeks ago
  • Joined: 2017-03-12

You can install GNU sed:

apk add --update-cache sed

Alternatively, you can put the -i flag before all the -e flags.

Log in or register to post comments