ip: RTNETLINK answers: Not supported

3 posts / 0 new
Last post
#1 Mon, 2017-03-27 00:12
Looper
  • Looper's picture
  • Offline
  • Last seen: 8 months 1 week ago
  • Joined: 2017-03-26

i edit /etc/network/interface for add static and persistent ip addresses but when i reboot my system , i get this ip: RTNETLINK answers: Not supported and eht 1 dosen't have any ip , but when ever i'm in and restart networking with service networking restart it's Done.
how can i fix it ?

Fri, 2017-09-29 03:10
Redhatter
  • Redhatter's picture
  • Offline
  • Last seen: 2 months 1 week ago
  • Joined: 2017-09-29
Tue, 2017-10-10 20:31
ingo
  • ingo's picture
  • Offline
  • Last seen: 2 months 1 day ago
  • Joined: 2017-10-10

thats my static settings in the interfaces file thats work. For the IPv6 part i had to do other settings to do as well.
Maybe this helps

auto lo
iface lo inet loopback
 
auto eth0
iface eth0 inet static
        address 10.1.0.172
        netmask 255.255.0.0
        gateway 10.1.0.253
 
iface eth0 inet static
        address 10.1.0.2
        netmask 255.255.0.0
 
iface eth0 inet6 static
        address xxxx:xxxx:xxxx:xxxx::172
        netmask 64
        gateway xxxx:xxxx:xxxx:xxxx::1
 
iface eth0 inet6 static
        address xxxx:xxxx:xxxx:xxxx::10
        netmask 64

Log in or register to post comments